Início » Aplicativos e Software » Como contar caracteres no Microsoft Excel

Como contar caracteres no Microsoft Excel

Por
44 semanas atrás

Se você precisa contar os caracteres no Excel, pode fazer isso individualmente para cada célula, ou também contar o número de caracteres de várias células ao mesmo tempo. Com essa fórmula em específico, você também pode somar os caracteres de cada célula, por exemplo, ou fazer outras operações dentro de outras funções do Excel.

Imagem por Esa Riutta/Pixabay

Como contar caracteres de uma célula no Excel

  1. Clique na célula ao lado da que você deseja contar os caracteres;
  2. Digite a fórmula =NÚM.CARACT() ;
  3. Dentro dos parênteses, digite a célula que você deseja contar caracteres, por exemplo, A1;
  4. A fórmula depende do idioma do seu Excel. Se não funcionar, tente =LEN()  ou =CARACT();
  5. Pronto! O Excel deve contar os caracteres da célula desejada, o que inclui letras, números, caracteres e espaços.

Como contar caracteres de várias células no Excel

  1. Clique na célula ao lado da que você deseja contar os caracteres;
  2. Digite a fórmula =NÚM.CARACT() ;
  3. Dentro dos parênteses, digite a célula que você deseja contar caracteres, por exemplo, A1;
  4. Coloque o mouse sobre a célula e segure o clique no quadradinho que fica no canto inferior direito da célula;
  5. Arraste o mouse para baixo até chegar ao comprimento das células que você quer contar os caracteres;
  6. Pronto! O Excel vai calcular, separadamente, os caracteres de cada célula desejada no espaço que você escolheu.

Como somar caracteres contados no Excel

Assim como várias funções no Excel, o bom é que essa fórmula também pode ser usada dentro de outras fórmulas. Neste exemplo, mostramos como somar os caracteres de várias células diferentes:

  1. Clique na célula ao lado da que você deseja contar os caracteres;
  2. Digite a fórmula =SOMA() ;
  3. Dentro dos parênteses, digite NÚM.CARACT() com a letra e o número da primeira célula para somar;
  4. Faça isso com outras células, separando por vírgulas;
  5. No final, deve ficar algo como =SOMA(NÚM.CARACT(A2),NÚM.CARACT(A3),NÚM.CARACT(A4)).

Compatibilidade da fórmula de contar de caracteres no Excel

Essa fórmula de contar caracteres foi testada no Microsoft Excel 2016 para Mac, em português. Em inglês, ela se chama =LEN(). Ela é compatível com as seguintes versões do Excel:

  • Office 365;
  • Excel 2016;
  • Excel 2013.

Infelizmente, a fórmula de contar caracteres no Excel não funciona na versão web.

Participe das conversas do Tecnoblog

Leia o post inteiro antes de comentar
e seja legal com seus amiguinhos.

Carregar Comentários Conheça nossa política de comentários aqui.