Início » Aplicativos e Software » Apple atualiza iPhone 4S, iPhone 5 e iPad 2 para corrigir falha no GPS

Apple atualiza iPhone 4S, iPhone 5 e iPad 2 para corrigir falha no GPS

Dispositivos precisam ser atualizados para não perderem a precisão do GPS a partir de novembro de 2019

André Fogaça Por

Ontem (23) a Apple liberou a versão 12.4 do iOS, além de outras atualizações para diversos produtos da empresa. Este é um passo que antecede o iOS 13 que deve ser lançado nos próximos meses, mas o que chamou atenção é que a leva de updates liberados nesta segunda-feira também incluiu outros aparelhos já obsoletos, como o iPhone 4S.

Lançado oito anos atrás, o iPhone 4S não é o único agraciado com a surpresa - para um modelo já fora de linha e que entrou na categoria de dispositivos obsoletos da Apple. A marca da maçã também liberou atualização para o iPad Mini de primeira geração (2012), iPad 2 (2011) e iPad de terceira geração (2012), além do iPad de quarta geração (2012) e o iPhone 5 (2012).

Infelizmente nenhum deles passa da grande última atualização de iOS que receberam e nem podem usufruir de novos recursos de software, pois o update apareceu apenas para evitar que os dispositivos encontrem problemas com a conexão com satélites GPS - e por isso apenas as versões com 3G/4G dos iPads listados foram atualizados.

O zelo com aparelhos mais antigos acontece por conta da forma como é calculada a localização, que depende de dados sobre hora e data. Este tipo de informação é armazenada em um conjunto de 10 bits, que a cada 20 anos a contagem de semanas é zerada.

A contagem é universal e aconteceu no dia 6 de abril para todos os dispositivos que utilizam GPS no mundo. Sem a atualização a localização fica imprecisa e isso afeta até mesmo aplicativos que dependem da data, como o Mail e a sincronização de dados com o iCloud. A Apple diz que seus dispositivos lançados até 2012 serão afetados por este problema a partir do dia 3 de novembro deste ano.

O update leva o iPhone 5 e iPad de quarta geração para o iOS 10.3.4, enquanto que o iPhone 4S, iPad mini de primeira geração, iPad 2 e iPad de terceira geração passam para o iOS 9.3.6. O problema não afeta os iPods Touch de qualquer geração.

Com informações: Apple.

Mais sobre: , ,