Malware para Linux invade sites usando 30 falhas diferentes

Cavalo de troia ataca plugins e temas desatualizados do WordPress em usuários do Linux; não há informações sobre o mesmo problema no Windows

Ricardo Syozi
Por

No fim de 2022, um novo malware do Linux foi descoberto. Ele consegue explorar 30 falhas distintas em vários plugins e temas do WordPress. Seu objetivo é o de injetar JavaScript maliciosos e oferecer ao operador comando remoto sobre os sistemas. Como resultado, hackers poderiam redirecionar os sites para diferentes propósitos.

Malware
Código no notebook (imagem ilustrativa: Christiaan Colen/Flickr)

O malware consegue afetar tanto versões 32-bit quanto de 64-bit do Linux. Ele usa uma série de exploits, um de cada vez, até que um deles acabe funcionando. Páginas do WordPress são o principal alvo, especialmente aquelas abandonadas ou mais antigas.

Segundo o vendedor de antivírus, Dr. Web, sites que usam versões desatualizadas dos plugins ou temas são os mais suscetíveis a receberem o ataque. Assim, o cavalo de troia automaticamente encontra uma opção viável para sua entrada e busca um JavaScript de seu servidor. Por fim, ele injeta o script.

A partir daí, o hacker pode criar várias formas para enganar o visitante, pois ele consegue redirecionar qualquer clique na página para outro local. Phishing, distribuição de malware e distintas campanhas são alguns exemplos dos propósitos.

Caso você use Linux, a melhor forma de se proteger é deixar todo o conteúdo interno de seu site no WordPress atualizado. Além disso, garantir que a ativação por dois fatores esteja ativada é um ponto extremamente importante para impedir invasões.

Também é válido ficar de olho na lista do que pode ser afetado em sua página.

Página afetada pelo Malware (Imagem: Reprodução / Dr. Web)
Página afetada pelo Malware (Imagem: Reprodução / Dr. Web)

Plugins e temas que podem sofrer o ataque

A primeira lista divulgada pelo Dr. Web traz 19 opções que são passíveis do cavalo de troia no WordPress:

  • WP Live Chat Support Plugin
  • WordPress – Yuzo Related Posts
  • Yellow Pencil Visual Theme Customizer Plugin
  • Easysmtp
  • WP GDPR Compliance Plugin
  • Newspaper Theme on WordPress Access Control (CVE-2016-10972)
  • Thim Core
  • Google Code Inserter
  • Total Donations Plugin
  • Post Custom Templates Lite
  • WP Quick Booking Manager
  • Facebook Live Chat by Zotabox
  • Blog Designer WordPress Plugin
  • WordPress Ultimate FAQ (CVE-2019-17232 and CVE-2019-17233)
  • WP-Matomo Integration (WP-Piwik)
  • WordPress ND Shortcodes For Visual Composer
  • WP Live Chat
  • Coming Soon Page and Maintenance Mode
  • Hybrid

No entanto, uma versão atualizada do malware já consegue afetar mais 11 add-ons:

  • Brizy WordPress Plugin
  • FV Flowplayer Video Player
  • WooCommerce
  • WordPress Coming Soon Page
  • WordPress theme OneTone
  • Simple Fields WordPress Plugin
  • WordPress Delucks SEO plugin
  • Poll, Survey, Form & Quiz Maker by OpinionStage
  • Social Metrics Tracker
  • WPeMatico RSS Feed Fetcher
  • Rich Reviews plugin

Com informações: Bleeping Computer.

Relacionados

Relacionados