Início » Aplicativos e Software » Apple avisa que iPhone 5 precisa ser atualizado até 3 de novembro

Apple avisa que iPhone 5 precisa ser atualizado até 3 de novembro

Apple atualiza iOS para resolver problema de GPS no iPhone 5, iPhone 4s, iPad 2, iPad 3 e iPad mini

Lucas Braga Por

O iPhone 5 foi lançado há 7 anos, mas ainda é utilizado no dia a dia de várias pessoas: a Apple avisa que quem tem este celular precisa atualizar o iOS para a versão 10.3.4 antes de 3 de novembro, para evitar problemas com serviços online. Além disso, o iPhone 4s, iPad mini, iPad 2 e iPad de 3ª geração com conectividade celular devem instalar o iOS 9.3.6.

Quem não atualizar o iOS para a versão mais recente encontrará problemas ao utilizar o iCloud, App Store, e-mail e navegação no Safari.

A atualização é importante porque altera a sequência de bits de contagem de tempo no GPS. O modelo atualmente adotado utiliza 10 bits, capaz de armazenar no máximo 1024 semanas, ou 19,7 anos. Após ultrapassar esse limite, o GPS recomeça a contagem e representa o tempo como "semana 0, 0 segundos". Esse procedimento também pode causar problemas em alguns dispositivos mais antigos, como navegadores GPS automotivos e rastreadores veiculares.

O iOS 10.3.4 foi disponibilizado em julho de 2019 para o iPhone 5 e iPad de 4ª geração. Por sua vez, o o iOS 9.3.6 está disponível para o iPhone 4s, iPad mini, iPad 2 e iPad de 3ª geração com conectividade celular.

Os usuários poderão fazer a atualização pelo próprio dispositivo até 3 de novembro de 2019, que é o último dia possível para usar o backup do iCloud e instalação via OTA. Quem perder esse prazo ainda conseguirá fazer o procedimento, mas somente pelo computador através do iTunes.

Com informações: MacRumors.